Mossberg 935 Problems

Discussion in 'Mossberg 935 Magnum Autoloader' started by Ksyotehunter, Mar 15, 2013.

  1. Ksyotehunter

    Ksyotehunter Copper BB

    Messages:
    5
    I have a Mossy 935 with a 26 inch barrel. I have a problem with the action moving slowly after a couple of shots I have cleaned the whole thing top to bottom 3 or 4 times. It worked smoothly in the house and when I get out to the field 2 shots then bam its gummy again. This was in the cold and warm weather.

    I can put my dads bolt in my gun and it works without a hitch. Anyone else have this problem. His working might just be cause it has been used more.
  2. MikeD

    MikeD I'm Your Huckleberry Staff Member Global Moderator Forum Moderator "Philanthropist"

    Messages:
    6,524
    I had the same issue with my 930 but it was a result of not cleaning it out when i got it. I had to do a complete breakdown and scrub it out good.

    Sent from my Mossberg 930 using Tapatalk2
  3. CDR_Glock

    CDR_Glock Copper BB

    Messages:
    7
    Do you have a rail mounted on the receiver? Your screws may be too long on it.
  4. Ksyotehunter

    Ksyotehunter Copper BB

    Messages:
    5
    Still having this problem. Don't know what to do next. Ill will look at were a scope would mount I don't have a mount on it but will make sure the screws aren't to long. Its weird my dads runs flawlessly and mine might work 15 mins. Just seems the action gets gummed up. I have cleaned this thing 3 times top to bottom.

    Thanks Travis

Share This Page